Home BGP Configurations Cisco 3-2-1. Cisco dual BGP with prefix Length (Load-balancing)

Cisco dual BGP with prefix Length (Load-balancing)

   
  • ISPs : 1
  • WAN links : 2
  • CPE : 1
  • PE : 2
  • Device : Cisco router with LAN/WAN ports.
  • WAN1 / Serial IP : 12.1.3.0/30 (mask 255.255.255.252)
  • WAN2 / Serial IP : 12.1.4.0/30 (mask 255.255.255.252)
  • Destination IP : 100.100.100.100 
  • LAN / Ethernet IP : 10.1.0.1/24 and 10.1.0.129/25(Secondary), are allocated by ISP.
  • Receiving Route : no route from ISP
  • LAN : ISP (AS20) and Customer (AS10)

 

BGP sample configuration 3-2-1

[Traffic flow]

Outbound traffic on CPE
All outbound traffic will go out thru both links. It is controlled by simple default route statement in this scenario. Outbound traffic won't be divided in exact 50/50. Because traffic will route to the link per destination(default) based, but not per packet. Don't worry, overall it make a balancing traffic. Most of ISPs are not supporting per packet option due to it is CPU intensive command(they said). 
 
 
Inbound traffic  on CPE
In this case we assumed that LAN side IP is fully used(/24). We will split it in half and announce it to Internet thru one of WANs.   We will announce /24 thru WAN1 and announce second half of /24, which is /25 block thru other WAN. So traffic targeted to first half of /24 will come thru WAN1 and other traffic will come thru WAN 2.
[CPE/Customer Cisco Router]
Current configuration:
!
version 12.x
!
hostname CPE
!
interface Ethernet0
description to Internal network
ip address 10.1.0.1 255.255.255.0
ip address 10.1.0.129 255.255.255.128 secondary
no ip directed-broadcast
no ip mroute-cache
!
interface Serial0
description to ISP A - WAN 1
ip address 12.1.3.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
description to ISP A - WAN 2
ip address 12.1.4.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
router bgp 10
no auto-summary
network 10.1.0.0 mask 255.255.255.0
network 10.1.0.128 mask 255.255.255.128
neighbor 12.1.3.2 remote-as 20
neighbor 12.1.3.2 version 4
neighbor 12.1.3.2 prefix-list 1 out
neighbor
12.1.4.2 remote-as 20
neighbor 12.1.4.2 version 4
neighbor 12.1.4.2 route-map redundancy out
!
ip classless
!
ip route 0.0.0.0 0.0.0.0 Serial0
ip route 0.0.0.0 0.0.0.0 Serial1
ip prefix-list 1 seq 5 permit 10.1.0.0/24 le 32
 
 
!
route-map redundancy permit 10
set as-path prepend 10 10 10
!
!
line con 0
line aux 0
line vty 0 4
login
!
end

[PE1 / ISP Cisco Router]
Current configuration:
!
version 12.x
!
hostname PE
!
!
interface Serial0
description to WAN 1
ip address 12.1.3.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
 
router bgp 20
no auto-summary
neighbor 12.1.3.1 remote-as 10
neighbor 12.1.3.1 version 4
neighbor 12.1.3.1 distribute-list 2 out <---no route sent
!
ip classless
!
access-list 2 deny   any
line con 0
line aux 0
line vty 0 4
login
!
end
[PE2 / ISP Cisco Router]
Current configuration:
!
version 12.x
!
hostname PE
!
!
interface Serial1
description to WAN 2
ip address 12.1.4.2 255.255.255.252
no ip mroute-cache
no ip directed-broadcast
no fair-queue
!
router bgp 20
no auto-summary
neighbor 12.1.4.1 remote-as 10
neighbor 12.1.4.1 version 4
neighbor 12.1.3.1 distribute-list 2 out <---no route sent
!
ip classless
!
access-list 2 deny   any
!
line con 0
line aux 0
line vty 0 4
login
!
end 

[Verifing output]

CPE# show ip bgp neighbors 12.1.3.2 ro
 
Total number of prefixes 0
CPE#
 
 
CPE# show ip bgp neighbors 12.1.4.2 ro
 
Total number of prefixes 0
CPE#
 
 
CPE# show ip bgp neighbors 12.1.3.2 ad
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      0.0.0.0                  0         32768 i

Total number of prefixes 1
CPE#
 
 
CPE# show ip bgp neighbors 12.1.4.2 ad
BGP table version is 3, local router ID is 1.1.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      0.0.0.0                  0         32768 i
*> 10.1.0.128/25    0.0.0.0                  0         32768 i

Total number of prefixes 2
CPE#
 
 
PE1#show ip bgp nei 12.1.3.1 ro
BGP table version is 50, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      12.1.3.1                 0             0 10 i

Total number of prefixes 1
PE1#
 
 
PE2#show ip bgp nei 12.1.4.1 ro
BGP table version is 71, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.0.0/24      12.1.4.1                 0             0 10 10 10 10 i
*> 10.1.0.128/25    12.1.4.1                 0             0 10 10 10 10 i

Total number of prefixes 2
PE2#
 
 
XR1#traceroute 10.1.0.129

Type escape sequence to abort.
Tracing the route to 10.1.0.129

  1 PE2 (20.4.5.1) 20 msec 28 msec 28 msec
  2 CPE (12.1.4.1) 56 msec *  68 msec

XR1#traceroute 10.1.0.1

Type escape sequence to abort.
Tracing the route to 10.1.0.1

  1 PE1 (20.3.5.1) 20 msec 28 msec 24 msec
  2 CPE (12.1.3.1) 60 msec *  60 msec
XR1# 

 

If you have any questions, feel free to send email us at contactus@showipbgp.com. If you are looking for professional grade service, you might want to try our "BGP experts service". What is "BGP Experts service"? Click "BGP Experts" from the top menu option. You will find out what the "BGP Experts" and what we are doing here for.

 
Google Translation
English Arabic Chinese (Simplified) Czech Dutch French German Italian Korean Portuguese Russian Spanish Filipino Vietnamese Thai Turkish
Statistics
Content View Hits : 548811
Polls
Who is the best ISP?
 
Global Route Table
Banner
Who's Online
We have 90 guests online
Related Items